Which browsers are supported for use with the UNC Campus listserver?
Description: Web Browsers Internet Explorer 10 Firefox 29 or higher The following web browsers are not officially supported, but should work: Netscape 8.1 Opera 7.x and later Mozilla 1.2x Safari Google Chrome
» Subjects: , » Tags: ,